libam7xxx-0.1.7 released

The libam7xxx-0.1.7 release is out; it's a maintenance release with no big new features.

libam7xxx is a library to communicate with USB pico-projectors like, for instance, the Philips/Sagemcom PicoPix devices; you can read more about it in some of the previous stories:

One notable change in this release is that FFMpeg 3.1+ is now required to build one of the example programs.

Building for Windows has also been improved.

Here is an overview from the NEWS file of the changes accumulated since the previous release:

News for v0.1.7:
================

  * Fix FFMpeg deprecation warnings, the code now depends on FFMpeg 3.1+ 
  * Fix compilation on Windows
  * Update the Windows build instructions in HACKING.asciidoc
  * Add a HOWTO for new users in contrib/howto-picopix.asciidoc
  * Add a patch to contrib/ to allow compiling libam7xxx on Ubuntu 14.04 LTS
  * Make sure am7xxx_get_device_info() always returns sensible values
  * Fix warnings about _BSD_SOURCE deprecation
  * Misc code and build system cleanups

The Debian packages have been kindly uploaded to Unstable by Gregor Herrmann.


CommentsSyndicate content

Hi Antonio, First of all

Bastien's picture

Hi Antonio,

First of all thank you very much for the work you' ve done writing this driver!

I have an Acer C120 and I'm trying to use it on my PC with Ubuntu 16.04 LTS.

I didn't really know how to proceed with your code, so I followed the instructions from this page: https://git.ao2.it/libam7xxx.git/blob/HEAD:/contrib/howto-picopix.asciidoc

I've installed the driver with: sudo apt-get install libam7xxx0.1-bin

Then I plugged my Acer C120 and I ran the following comand:
am7xxx-play -f x11grab -i :0.0

But I got this message:
scan_devices[919]: Cannot find any device to open
am7xxx_open_device: No such device

Did I do something wrong, did I miss something?

Thank you very much for your help :)
Bastien

Hi Bastien, the Acer C120 is

ao2's picture

Hi Bastien,

the Acer C120 is not based on the AM7XXX chip so it won't work with libam7xxx.

The good news is that there is a kernel driver written by Hans de Goede for it, see https://ao2.it/news/2015/07/08/linux-kms-driver-acer-c120.

Having a kernel driver means that the Acer C120 will work even better than AM7XXX projectors.

I think Hans also tried to submit the driver for inclusion into the mainline linux tree, but I am not sure what the status is, you can ask him.

Ciao, Antonio

Hi Antonio, Thanks for your

Bastien's picture

Hi Antonio,

Thanks for your response. I didn't realize your code wasn't conceived for the Acer120, my mistake.

I tried the kernel driver from Hans. I have a problem during the compilation so I'll try to contact him directly.

Anyway, thank you very much.

Bastien

Do you know how/where I could

Bastien's picture

Do you know how/where I could contact him?

If you look at any of the

ao2's picture

If you look at any of the commits in the gm12u320-kms git repository you can find his e-mail address.

Thank you for the update. I

Rickyx's picture

Thank you for the update.
I have installed in Debian Buster libam7xxx (0.1.7-1) from the standard sources but I have some troubles:
trying the command "am7xxx-play -f x11grab -i :0.0 -o video_size=800x480" I display only my mouse cursor (correctly) on a black background: what is on my desktop does not show ...

Do you have any suggestion?
Thank you,
Rickyx

Hi Rickyx, IIRC the

ao2's picture

Hi Rickyx,

IIRC the video_size=800x480 option does not rescale the input, so it might be that you are projecting only a portion of the screen.

Try without the option, or change the screen resolution.

Ciao, Antonio

Grazie Antonio, I tried

Rickyx's picture

Grazie Antonio,

I tried without the option but is the whole screen black:
I done a video demonstrating the problem (sorry for the low quality): https://we.tl/t-C2hznfgJJB

On the left you can see the projected mouse on a black background: I'm for sure missing some option.
I'm using Gnome with Wayland, don't know if it is interesting...

Grazie ancora,
Riccardo

Ah, the x11grab input format

ao2's picture

Ah, the x11grab input format assumes a full X11 setup, using it under Wayland may capture Xwayland which is used only for backwards compatibility with some applications and does not manage the whole screen.

Capturing the screen under Wayland is trickier (see here for some info) and ffmpeg, which am7xxx-play is based on, does not support it.

You may try different solutions:

  • using GNOME in an Xorg session. Debian makes it very easy, look at the GDM login screen;
  • try the kmsgrab input format but that does not work with some drivers;
  • write something Gnome-specific, it looks like the org.gnome.Shell.Screencast service relies on GStreamer, so using gst-am7xxxsink should not be too hard. I looked at green-recorder and the code is easy to follow, that could be the base for an experiment.

Ciao, Antonio

GNOME in an Xorg session

Rickyx's picture

GNOME in an Xorg session works perfectly!

Thank you for the software and the help,
Rickyx

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account associated with the e-mail address you provide, it will be used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Lines and paragraphs break automatically.

More information about formatting options

CAPTCHA
This question is for testing whether you are a human visitor and to prevent automated spam submissions.
K
D
Q
E
6
s
Enter the code without spaces.