Tweeper 1.4.3 released, twitter to RSS conversion is back once again

Tweeper is a web scraper which converts Twitter and other social media websites to RSS.

On December 27th 2020 version 1.4.3 of Tweeper has been released. The tweeper Debian package has also been updated.

For PHP composer users there is also ao2/tweeper on packagist, which means that tweeper can be installed and run with these commands:

$ composer global require ao2/tweeper
$ ~/.config/composer/vendor/bin/tweeper

Version 1.4.3 is a maintenance release with a couple of fixes.

Here are the NEWS file entries:

News for v1.4.3:
================

  * Fix scraping twitter.com again by impersonating a Google crawler
  * Add check for http response code and return failure for error codes
  * Return failure when instagram.com redirects to login page


CommentsSyndicate content

I get this when I try to use

GunnarG's picture

I get this when I try to use compose:

Changed current directory to /home/user/.config/composer
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2
Using version ^1.4 for ao2/tweeper
./composer.json has been updated
Loading composer repositories with package information
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- friendsofphp/php-cs-fixer v2.10.4 requires php ^5.6 || >=7.0 <7.3 -> your PHP version (7.4.3) does not satisfy that requirement.
- friendsofphp/php-cs-fixer v2.10.4 requires php ^5.6 || >=7.0 <7.3 -> your PHP version (7.4.3) does not satisfy that requirement.
- friendsofphp/php-cs-fixer v2.10.4 requires php ^5.6 || >=7.0 <7.3 -> your PHP version (7.4.3) does not satisfy that requirement.
- Installation request for friendsofphp/php-cs-fixer (locked at v2.10.4, required as ^2.10) -> satisfiable by friendsofphp/php-cs-fixer[v2.10.4].

Using composer like this

GunnarG's picture

Using composer like this fixes the issue for me.
composer global require --ignore-platform-reqs ao2/tweeper

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account associated with the e-mail address you provide, it will be used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Lines and paragraphs break automatically.

More information about formatting options

CAPTCHA
This question is for testing whether you are a human visitor and to prevent automated spam submissions.
g
E
s
e
u
r
Enter the code without spaces.